using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[g|p][uch|ch|ss|us|si|ui|sl|ul|f|d|t|e|u]([A-Z][a-z]*([A-Z][a-z]*)*)$";
string input = @"Variable-Hungara";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}