re = /^[g|p][uch|ch|ss|us|si|ui|sl|ul|f|d|t|e|u]([A-Z][a-z]*([A-Z][a-z]*)*)$/m
str = 'Variable-Hungara'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end