$re = '/^[g|p][uch|ch|ss|us|si|ui|sl|ul|f|d|t|e|u]([A-Z][a-z]*([A-Z][a-z]*)*)$/m';
$str = 'Variable-Hungara';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);