#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\\(ref){eq:(.*?)}"
Local $sString = "\ref{eq:0And1Qubit} hjhg" & @CRLF & _
"\ref{eq:EulerForm}the state is measured, as it can be shown $|\rho e^{i\theta}|^2=\rho^2$ ($i$ is always the imaginary unit in this report). In other words, it is not possible to measure the global phase. The description of $\ket{q}$ can then be confined to $\alpha,\beta,\phi\in\mathbb{R}$, where $\phi$ is the relative phase $\phi=\theta_\beta-\theta_\alpha$."
Local $sSubst = "\\eqref{eq:$2}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)