// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\\(ref){eq:(.*?)}").unwrap();
let string = "\\ref{eq:0And1Qubit} hjhg
\\ref{eq:EulerForm}the state is measured, as it can be shown $|\\rho e^{i\\theta}|^2=\\rho^2$ ($i$ is always the imaginary unit in this report). In other words, it is not possible to measure the global phase. The description of $\\ket{q}$ can then be confined to $\\alpha,\\beta,\\phi\\in\\mathbb{R}$, where $\\phi$ is the relative phase $\\phi=\\theta_\\beta-\\theta_\\alpha$.";
let substitution = "\\\\eqref{eq:$2}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}