#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:htt(?:ps|p):\/\/)?(.*com)(\/?.*)$"
Local $sString = "env1-www-uk.my.domain.com" & @CRLF & _
"env2-www-uk.my.domain.com" & @CRLF & _
"http://env1-www-uk.my.domain.com" & @CRLF & _
"http://env1-www-uk.my.domain.asd.net.com" & @CRLF & _
"https://env1-www-uk.my.domain.com" & @CRLF & _
"env1-www-uk.my.domain.com/something123" & @CRLF & _
"env2-www-uk.my.domain.com/some%20more/stuff-too/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")