use strict;
my $str = 'env1-www-uk.my.domain.com
env2-www-uk.my.domain.com
http://env1-www-uk.my.domain.com
http://env1-www-uk.my.domain.asd.net.com
https://env1-www-uk.my.domain.com
env1-www-uk.my.domain.com/something123
env2-www-uk.my.domain.com/some%20more/stuff-too/';
my $regex = qr/^(?:htt(?:ps|p):\/\/)?(.*com)(\/?.*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}