using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:htt(?:ps|p):\/\/)?(.*com)(\/?.*)$";
string input = @"env1-www-uk.my.domain.com
env2-www-uk.my.domain.com
http://env1-www-uk.my.domain.com
http://env1-www-uk.my.domain.asd.net.com
https://env1-www-uk.my.domain.com
env1-www-uk.my.domain.com/something123
env2-www-uk.my.domain.com/some%20more/stuff-too/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}