using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\r?\n(message.*?)(?=\r?\nmessage|$)";
string input = @"abcdefg
message {
}
message {
dadsfa
message { asdfadfadsf }
}
message {
gfgfgfgdfgsfdggsdfg
}";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}