import re
regex = re.compile(r"\r?\n(message.*?)(?=\r?\nmessage|$)", flags=re.DOTALL)
test_str = ("abcdefg\n\n\n"
"message {\n\n"
"}\n"
"message {\n"
"dadsfa\n"
" message { asdfadfadsf }\n"
"}\n"
"message {\n\n"
"gfgfgfgdfgsfdggsdfg\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")