$re = '/\r?\n(message.*?)(?=\r?\nmessage|$)/s';
$str = 'abcdefg
message {
}
message {
dadsfa
message { asdfadfadsf }
}
message {
gfgfgfgdfgsfdggsdfg
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);