const regex = /(?<log>(?<ymdhm>\d{4}-\d{2}-\d{2} \d{2}:\d{2}).*?(?<flag>Starting)$)\n\k<ymdhm>.*?\k<flag>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<log>(?<ymdhm>\\d{4}-\\d{2}-\\d{2} \\d{2}:\\d{2}).*?(?<flag>Starting)$)\\n\\k<ymdhm>.*?\\k<flag>', 'gm')
const str = `2019-10-31 06:53:58.416 +10:00 [1] - Not Started
2019-10-31 05:49:52.416 +10:00 [1] - Starting
2019-10-31 05:49:52.416 +10:00 [1] - Starting
2019-10-31 05:49:53.416 +10:00 [1] - Starting
2019-10-31 05:50:53.416 +10:00 [1] - Starting
2019-10-31 06:53:58.416 +10:00 [1] - Starting
2019-10-31 06:53:59.416 +10:00 [1] - Starting
2019-10-31 06:53:58.416 +10:00 [1] - Ended`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}