re = /(?<log>(?<ymdhm>\d{4}-\d{2}-\d{2} \d{2}:\d{2}).*?(?<flag>Starting)$)\n\k<ymdhm>.*?\k<flag>/m
str = '2019-10-31 06:53:58.416 +10:00 [1] - Not Started
2019-10-31 05:49:52.416 +10:00 [1] - Starting
2019-10-31 05:49:52.416 +10:00 [1] - Starting
2019-10-31 05:49:53.416 +10:00 [1] - Starting
2019-10-31 05:50:53.416 +10:00 [1] - Starting
2019-10-31 06:53:58.416 +10:00 [1] - Starting
2019-10-31 06:53:59.416 +10:00 [1] - Starting
2019-10-31 06:53:58.416 +10:00 [1] - Ended'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end