import re
regex = re.compile(r"(?<log>(?<ymdhm>\d{4}-\d{2}-\d{2} \d{2}:\d{2}).*?(?<flag>Starting)$)\n\k<ymdhm>.*?\k<flag>", flags=re.MULTILINE)
test_str = ("2019-10-31 06:53:58.416 +10:00 [1] - Not Started\n"
"2019-10-31 05:49:52.416 +10:00 [1] - Starting\n"
"2019-10-31 05:49:52.416 +10:00 [1] - Starting\n"
"2019-10-31 05:49:53.416 +10:00 [1] - Starting\n"
"2019-10-31 05:50:53.416 +10:00 [1] - Starting\n"
"2019-10-31 06:53:58.416 +10:00 [1] - Starting\n"
"2019-10-31 06:53:59.416 +10:00 [1] - Starting\n"
"2019-10-31 06:53:58.416 +10:00 [1] - Ended")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")