re = /(<.*”>)(.*)(<\/.*)/m
str = '<p style=“text-align:center; others-style:value;”>Content</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end