using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"IVR\/\d{8}\/(M{0,4}(?:CM|CD|D?C{0,3})(?:XC|XL|L?X{0,3})(?:IX|IV|V?I{0,3}))\/(M{0,4}(?:CM|CD|D?C{0,3})(?:XC|XL|L?X{0,3})(?:IX|IV|V?I{0,3}))\/(\d{7,9})";
string input = @"your invoice number IVR/20170531/XVII/V/12652967 and IVR/20170531/XVII/V/13652967";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}