re = /IVR\/\d{8}\/(M{0,4}(?:CM|CD|D?C{0,3})(?:XC|XL|L?X{0,3})(?:IX|IV|V?I{0,3}))\/(M{0,4}(?:CM|CD|D?C{0,3})(?:XC|XL|L?X{0,3})(?:IX|IV|V?I{0,3}))\/(\d{7,9})/
str = 'your invoice number IVR/20170531/XVII/V/12652967 and IVR/20170531/XVII/V/13652967'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end