#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9][a-zA-Z0-9-_.\\h+]{4,8}+(?>[a-zA-Z0-9-_.\\h+]{2}(?>[a-zA-Z0-9-_.\\h+]{2,19})?)?$"
Local $sString = "1bcd" & @CRLF & _
"1bcde" & @CRLF & _
"1bcdef" & @CRLF & _
"1bcdefg" & @CRLF & _
"1bcdefgh" & @CRLF & _
"1bcdefghi" & @CRLF & _
"1bcdefghij" & @CRLF & _
"1bcdefghijk" & @CRLF & _
"1bcdefghijkl" & @CRLF & _
"1bcdefghijklm" & @CRLF & _
"1bcdefghijklmnopqrstuvwxyzabc" & @CRLF & _
"1bcdefghijklmnopqrstuvwxyzabcd" & @CRLF & _
"1bcdefghijklmnopqrstuvwxyzabcde" & @CRLF & _
"1bcdefghijklmnopqrstuvwxyzabcdefghijk" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")