use strict;
my $str = '1bcd
1bcde
1bcdef
1bcdefg
1bcdefgh
1bcdefghi
1bcdefghij
1bcdefghijk
1bcdefghijkl
1bcdefghijklm
1bcdefghijklmnopqrstuvwxyzabc
1bcdefghijklmnopqrstuvwxyzabcd
1bcdefghijklmnopqrstuvwxyzabcde
1bcdefghijklmnopqrstuvwxyzabcdefghijk
';
my $regex = qr/^[0-9][a-zA-Z0-9-_.\\h+]{4,8}+(?>[a-zA-Z0-9-_.\\h+]{2}(?>[a-zA-Z0-9-_.\\h+]{2,19})?)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}