#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[\d]+[\,]?[\d]+"
Local $sString = "<td bgcolor="#EFEFEF"><div align="center"><font size="2" face="Arial, Helvetica, sans-serif"><strong><br>" & @CRLF & _
" Nota" & @CRLF & _
" Final 56,987<br>" & @CRLF & _
" <br>" & @CRLF & _
" Classificação no sistema universal em 1ª opção 08028 " & @CRLF & _
" <br>" & @CRLF & _
" <br>" & @CRLF & _
" <br>" & @CRLF & _
" Classificação em 2ª opção 04516 " & @CRLF & _
" <br>" & @CRLF & _
" <br>" & @CRLF & _
" </strong></font></div></td>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")