# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\d]+[\,]?[\d]+"
test_str = ("<td bgcolor=\"#EFEFEF\"><div align=\"center\"><font size=\"2\" face=\"Arial, Helvetica, sans-serif\"><strong><br>\n"
" Nota\n"
" Final 56,987<br>\n"
" <br>\n"
" Classificação no sistema universal em 1ª opção 08028 \n"
" <br>\n"
" <br>\n"
" <br>\n"
" Classificação em 2ª opção 04516 \n"
" <br>\n"
" <br>\n"
" </strong></font></div></td>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.