$re = '/[\d]+[\,]?[\d]+/';
$str = '<td bgcolor="#EFEFEF"><div align="center"><font size="2" face="Arial, Helvetica, sans-serif"><strong><br>
Nota
Final 56,987<br>
<br>
Classificação no sistema universal em 1ª opção 08028
<br>
<br>
<br>
Classificação em 2ª opção 04516
<br>
<br>
</strong></font></div></td>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);