import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\[\\[)([^\\]\\[]*)(?=\\]\\])";
final String string = "==///Listings==/?\n"
+ "assadsadsadsa\n"
+ "adasdsad\n"
+ "</test>\n"
+ "''[[excellent wheat|excellent wheat]]''\n"
+ "''[[brilliant corn|Tom's brilliant corn]]''\n"
+ "</separation>\n"
+ "Remember to purchase this if on offer\n"
+ "''[[jub|jub/ha]]'',\n"
+ "''[[barley|barley/hops]]''\n"
+ "zcxcxzcxz";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}