$re = '/(?<=\[\[)([^\]\[]*)(?=\]\])/m';
$str = '==///Listings==/?
assadsadsadsa
adasdsad
</test>
\'\'[[excellent wheat|excellent wheat]]\'\'
\'\'[[brilliant corn|Tom\'s brilliant corn]]\'\'
</separation>
Remember to purchase this if on offer
\'\'[[jub|jub/ha]]\'\',
\'\'[[barley|barley/hops]]\'\'
zcxcxzcxz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);