re = /(?<=\[\[)([^\]\[]*)(?=\]\])/m
str = '==///Listings==/?
assadsadsadsa
adasdsad
</test>
\'\'[[excellent wheat|excellent wheat]]\'\'
\'\'[[brilliant corn|Tom\'s brilliant corn]]\'\'
</separation>
Remember to purchase this if on offer
\'\'[[jub|jub/ha]]\'\',
\'\'[[barley|barley/hops]]\'\'
zcxcxzcxz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end