# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)\b(blue|red)\b(?=.*:\1=(\w+)\b)/\2/gs;t' <<< "blue cheese, a red nose.
Dictionary:blue=bleu:red=rouge:green=vert"