using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)\b(blue|red)\b(?=.*:\1=(\w+)\b)";
string substitution = @"\2";
string input = @"blue cheese, a red nose.
Dictionary:blue=bleu:red=rouge:green=vert";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}