#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<DIV align=center><DIV class=title>([\s\S]+?)\s*<\/DIV>"
Local $sString = "<script type="text/javascript">" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"title="Территория питомника обезьян в Адлере" hspace='0' vspace=3 border=0 ></A></TD></TR>" & @CRLF & _
"<TR><TD valign=top height=0></TD></TR>" & @CRLF & _
"</TABLE></TD></TR>" & @CRLF & _
"Фото- и видеосъёмка на территории бесплатная." & @CRLF & _
"</TD></TR>" & @CRLF & _
"<TR><TD><DIV align=center><DIV class=title>Адлерский (Сочинский) Обезьяний Питомник<br>" & @CRLF & _
"г. Сочи, Адлерский район, с. Веселое-1<br>" & @CRLF & _
"+7 (8622) 42-28-84, +7 (8622) 42-28-62" & @CRLF & _
"</DIV></DIV></TD></TR>" & @CRLF & _
"</TABLE>" & @CRLF & _
"</div>" & @CRLF & _
"<TR><TD><A href="http://i.azur.ru/aimg/73/4373_bb06d.jpg" target=_new rel=clearbox[gallery=,,type=image] alt="" title=""><IMG src="http://i.azur.ru/aimg/73/4373_bb06d_th.jpg" width='219' height='146' alt="" title="" hspace='0' vspace=3 border=0 ></A><A href="http://i.azur.ru/aimg/73/4373_a92a1.jpg" target=_new rel=clearbox[gallery=,,type=image] alt="" title=""><IMG src="http://i.azur.ru/aimg/73/4373_a92a1_th.jpg" width='219' height='146' alt="" title="" hspace='10' vspace=3 border=0 ></A><A href="http://i.azur.ru/aimg/73/4373_da60b.jpg" target=_new rel=clearbox[gallery=,,type=image] alt="" title=""><IMG src="http://i.azur"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")