$re = '/<DIV align=center><DIV class=title>([\s\S]+?)\s*<\/DIV>/i';
$str = '<script type="text/javascript">
title="Территория питомника обезьян в Адлере" hspace=\'0\' vspace=3 border=0 ></A></TD></TR>
<TR><TD valign=top height=0></TD></TR>
</TABLE></TD></TR>
Фото- и видеосъёмка на территории бесплатная.
</TD></TR>
<TR><TD><DIV align=center><DIV class=title>Адлерский (Сочинский) Обезьяний Питомник<br>
г. Сочи, Адлерский район, с. Веселое-1<br>
+7 (8622) 42-28-84, +7 (8622) 42-28-62
</DIV></DIV></TD></TR>
</TABLE>
</div>
<TR><TD><A href="http://i.azur.ru/aimg/73/4373_bb06d.jpg" target=_new rel=clearbox[gallery=,,type=image] alt="" title=""><IMG src="http://i.azur.ru/aimg/73/4373_bb06d_th.jpg" width=\'219\' height=\'146\' alt="" title="" hspace=\'0\' vspace=3 border=0 ></A><A href="http://i.azur.ru/aimg/73/4373_a92a1.jpg" target=_new rel=clearbox[gallery=,,type=image] alt="" title=""><IMG src="http://i.azur.ru/aimg/73/4373_a92a1_th.jpg" width=\'219\' height=\'146\' alt="" title="" hspace=\'10\' vspace=3 border=0 ></A><A href="http://i.azur.ru/aimg/73/4373_da60b.jpg" target=_new rel=clearbox[gallery=,,type=image] alt="" title=""><IMG src="http://i.azur';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);