import re
regex = re.compile(r"<DIV align=center><DIV class=title>([\s\S]+?)\s*<\/DIV>", flags=re.IGNORECASE)
test_str = ("<script type=\"text/javascript\">\n"
" \n\n"
"title=\"Территория питомника обезьян в Адлере\" hspace='0' vspace=3 border=0 ></A></TD></TR>\n"
"<TR><TD valign=top height=0></TD></TR>\n"
"</TABLE></TD></TR>\n"
"Фото- и видеосъёмка на территории бесплатная.\n"
"</TD></TR>\n"
"<TR><TD><DIV align=center><DIV class=title>Адлерский (Сочинский) Обезьяний Питомник<br>\n"
"г. Сочи, Адлерский район, с. Веселое-1<br>\n"
"+7 (8622) 42-28-84, +7 (8622) 42-28-62\n"
"</DIV></DIV></TD></TR>\n"
"</TABLE>\n"
"</div>\n"
"<TR><TD><A href=\"http://i.azur.ru/aimg/73/4373_bb06d.jpg\" target=_new rel=clearbox[gallery=,,type=image] alt=\"\" title=\"\"><IMG src=\"http://i.azur.ru/aimg/73/4373_bb06d_th.jpg\" width='219' height='146' alt=\"\" title=\"\" hspace='0' vspace=3 border=0 ></A><A href=\"http://i.azur.ru/aimg/73/4373_a92a1.jpg\" target=_new rel=clearbox[gallery=,,type=image] alt=\"\" title=\"\"><IMG src=\"http://i.azur.ru/aimg/73/4373_a92a1_th.jpg\" width='219' height='146' alt=\"\" title=\"\" hspace='10' vspace=3 border=0 ></A><A href=\"http://i.azur.ru/aimg/73/4373_da60b.jpg\" target=_new rel=clearbox[gallery=,,type=image] alt=\"\" title=\"\"><IMG src=\"http://i.azur")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")