const regex = /(\d{13})|(\d{1}\s\d{4}\s\d{5}\s\d{2}\s\d{1})|(\d{5}\s\d{5}\s\d{3})|(\d{5}\s\d{5}\s\d{2}\s\d{1})|(\d{1}\-?\d{4}\-?\d{5}\-?\d{2}\-?\d{1})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{13})|(\\d{1}\\s\\d{4}\\s\\d{5}\\s\\d{2}\\s\\d{1})|(\\d{5}\\s\\d{5}\\s\\d{3})|(\\d{5}\\s\\d{5}\\s\\d{2}\\s\\d{1})|(\\d{1}\\-?\\d{4}\\-?\\d{5}\\-?\\d{2}\\-?\\d{1})', 'g')
const str = `1100800612202
1 1008 00612 20 2
11008 00612 202
11008 00612 20 2
1-1008-00612-20-2
11008-00612-202
11008-00612-20-2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}