#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miu)^([1-9][0-9]*(?:-[1-9][0-9]*)*)[\s,-]+(?:(bis|ter|qua)[\s,-]+)?([\w]+[\-\w]*)[\s,]+([-\w].+)$"
Local $sString = "51 bis rue du 26eme régiment d'infanterie" & @CRLF & _
"51 ter rue du 26eme régiment d'infanterie" & @CRLF & _
"51,bis,rue du 26eme régiment d'infanterie" & @CRLF & _
"51 rue du 26eme régiment d'infanterie" & @CRLF & _
"51 rue d'Alençon et son apostrophe" & @CRLF & _
"51 rue ,du 26eme régiment d'infanterie avec une virgule qui traine" & @CRLF & _
"51 bis contre-allée du tiret dans le type de voie" & @CRLF & _
"51 rue équateur avec accent en premier caractère de nom de voie" & @CRLF & _
"51- rue du tiret inutile après le chiffre" & @CRLF & _
"10-12 rue de l'intervalle de numéros de rue" & @CRLF & _
"10-12-14-18 rue de l'intervalle beaucoup trop long" & @CRLF & _
"51 bis rue -de ' ; la - ,po-nctuation mise n'importe où" & @CRLF & _
"51 bis - rue - du 26eme régiment d'infanterie"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")