const regex = /^([1-9][0-9]*(?:-[1-9][0-9]*)*)[\s,-]+(?:(bis|ter|qua)[\s,-]+)?([\w]+[\-\w]*)[\s,]+([-\w].+)$/gmiu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([1-9][0-9]*(?:-[1-9][0-9]*)*)[\\s,-]+(?:(bis|ter|qua)[\\s,-]+)?([\\w]+[\\-\\w]*)[\\s,]+([-\\w].+)$', 'gmiu')
const str = `51 bis rue du 26eme régiment d'infanterie
51 ter rue du 26eme régiment d'infanterie
51,bis,rue du 26eme régiment d'infanterie
51 rue du 26eme régiment d'infanterie
51 rue d'Alençon et son apostrophe
51 rue ,du 26eme régiment d'infanterie avec une virgule qui traine
51 bis contre-allée du tiret dans le type de voie
51 rue équateur avec accent en premier caractère de nom de voie
51- rue du tiret inutile après le chiffre
10-12 rue de l'intervalle de numéros de rue
10-12-14-18 rue de l'intervalle beaucoup trop long
51 bis rue -de ' ; la - ,po-nctuation mise n'importe où
51 bis - rue - du 26eme régiment d'infanterie`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}