import re
regex = re.compile(r"^([1-9][0-9]*(?:-[1-9][0-9]*)*)[\s,-]+(?:(bis|ter|qua)[\s,-]+)?([\w]+[\-\w]*)[\s,]+([-\w].+)$", flags=re.MULTILINE | re.IGNORECASE | re.UNICODE)
test_str = ("51 bis rue du 26eme régiment d'infanterie\n"
"51 ter rue du 26eme régiment d'infanterie\n"
"51,bis,rue du 26eme régiment d'infanterie\n"
"51 rue du 26eme régiment d'infanterie\n"
"51 rue d'Alençon et son apostrophe\n"
"51 rue ,du 26eme régiment d'infanterie avec une virgule qui traine\n"
"51 bis contre-allée du tiret dans le type de voie\n"
"51 rue équateur avec accent en premier caractère de nom de voie\n"
"51- rue du tiret inutile après le chiffre\n"
"10-12 rue de l'intervalle de numéros de rue\n"
"10-12-14-18 rue de l'intervalle beaucoup trop long\n"
"51 bis rue -de ' ; la - ,po-nctuation mise n'importe où\n"
"51 bis - rue - du 26eme régiment d'infanterie")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")