package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([[:alnum:]_]+[[:space:]]){1,5}\((\S+\.[[:alpha:]]):([[:digit:]]+)\)\.$`)
var str = `0xffffffc0006e0584 is in some_function (/path/to/my/file.c:93).`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}