re = /^([[:alnum:]_]+[[:space:]]){1,5}\((\S+\.[[:alpha:]]):([[:digit:]]+)\)\.$/m
str = '0xffffffc0006e0584 is in some_function (/path/to/my/file.c:93).'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end