import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([[:alnum:]_]+[[:space:]]){1,5}\\((\\S+\\.[[:alpha:]]):([[:digit:]]+)\\)\\.$";
final String string = "0xffffffc0006e0584 is in some_function (/path/to/my/file.c:93).";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}