package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Total:\s\$\d+.\d+`)
var str = `02-01 00:00 02-28 23:59$10.00 $0.00 $10.00Subtotal: $10.00Tax: $0.00Total: $10.00Thanks for your purchase!Please do not hesitate to contact us if you have any questions.(View as PDF...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}