import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Total:\\s\\$\\d+.\\d+";
final String string = "02-01 00:00 02-28 23:59$10.00 $0.00 $10.00Subtotal: $10.00Tax: $0.00Total: $10.00Thanks for your purchase!Please do not hesitate to contact us if you have any questions.(View as PDF...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}