use strict;
my $str = '02-01 00:00 02-28 23:59$10.00 $0.00 $10.00Subtotal: $10.00Tax: $0.00Total: $10.00Thanks for your purchase!Please do not hesitate to contact us if you have any questions.(View as PDF...';
my $regex = qr/Total:\s\$\d+.\d+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}