package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d(?:[\h/-]*\d){8}`)
var str = `
все номера только 9-и значные и могут содержать в начале 2 или 9, т.е
923456789 или 223456789
могут содержать различные разделители без особых правил (пробелы, /, -), например:
91 / 123-45 67
могут содержать код страны +123 или (123), его не учитывать, т.е. (123) 912345678, действительный номер 912345678
оба номера могут разделяются с: пробел(ы), /, -, причём этот символ являются разделителем только если с правой стороны находится действительный номер как описано выше, например: 243 / 91-23 45 678, действителен второй номер 912345678`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}