const regex = new RegExp('\\d(?:[\\h/-]*\\d){8}', 'g')
const str = `
все номера только 9-и значные и могут содержать в начале 2 или 9, т.е
923456789 или 223456789
могут содержать различные разделители без особых правил (пробелы, /, -), например:
91 / 123-45 67
могут содержать код страны +123 или (123), его не учитывать, т.е. (123) 912345678, действительный номер 912345678
оба номера могут разделяются с: пробел(ы), /, -, причём этот символ являются разделителем только если с правой стороны находится действительный номер как описано выше, например: 243 / 91-23 45 678, действителен второй номер 912345678`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}