import re
regex = re.compile(r"\d(?:[\h/-]*\d){8}")
test_str = ("\n"
"все номера только 9-и значные и могут содержать в начале 2 или 9, т.е\n"
"923456789 или 223456789\n"
"могут содержать различные разделители без особых правил (пробелы, /, -), например:\n"
"91 / 123-45 67\n"
"могут содержать код страны +123 или (123), его не учитывать, т.е. (123) 912345678, действительный номер 912345678\n"
"оба номера могут разделяются с: пробел(ы), /, -, причём этот символ являются разделителем только если с правой стороны находится действительный номер как описано выше, например: 243 / 91-23 45 678, действителен второй номер 912345678")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")