#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w+(?=-[^-]*$)"
Local $sString = "sds-rwewr-dddd-cash0-bbb" & @CRLF & _
"rrse-cash1-nonre" & @CRLF & _
"loan-snk-cash2-ssdd" & @CRLF & _
"garb-cash3-dfgfd" & @CRLF & _
"loan-unwan-cash4-something"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")