import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+(?=-[^-]*$)";
final String string = "sds-rwewr-dddd-cash0-bbb\n"
+ "rrse-cash1-nonre\n"
+ "loan-snk-cash2-ssdd\n"
+ "garb-cash3-dfgfd\n"
+ "loan-unwan-cash4-something";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}