$re = '/\w+(?=-[^-]*$)/m';
$str = 'sds-rwewr-dddd-cash0-bbb
rrse-cash1-nonre
loan-snk-cash2-ssdd
garb-cash3-dfgfd
loan-unwan-cash4-something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);