package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<host>.*(vmss)?\D)`)
var str = `aks-agentpool-60893500-2
aks-nodes-15133334-vmss000002`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}