re = /(?<host>.*(vmss)?\D)/m
str = 'aks-agentpool-60893500-2
aks-nodes-15133334-vmss000002'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end