$re = '/(?<host>.*(vmss)?\D)/m';
$str = 'aks-agentpool-60893500-2
aks-nodes-15133334-vmss000002';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);