package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\([^\]()*(?:USCS|§)[^\]()*)`)
var str = ` asdasdas asdsadsadsa sadasdsadsadsadsa(RSVP dog) [§111)] [cat] (§111 asdasadsa) asdasdsadsadsadsadsadsadsadsa asdasd asdsadsadsadsadsadsadsadsadsadsadsasdadsasadsadsadsadsadsadsadsasad`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}